Need help? Chat now!

Hostwinds Tutorials

Zoekresultaten voor:


Inhoudsopgave


Joomla! Basissysteemvereisten
Joomla! Aanbevolen systeemvereisten

Joomla! systeem vereisten

Trefwoorden: Joomla 

Joomla! Basissysteemvereisten
Joomla! Aanbevolen systeemvereisten

Bij het installeren van Joomla zijn er bepaalde vereisten die Joomla moet ontmoeten om te lopen omdat er verschillende versies van Joomla zijn.Dit artikel is geschreven om nuttig te zijn voor de nieuwste versie op het moment van schrijven.Dit is Joomla 3.x, waar 'X een nummer is dat helpt bij het beschrijven van de huidige versie.De basis en aanbevolen vereisten voor Joomla naar functie worden hieronder vermeld.

Joomla! Basissysteemvereisten

  • PHP-versie: Moet hoger zijn dan PHP-versie 5.3.10. Dit zou geen probleem moeten zijn, aangezien deze versie al lang verouderd is. Op al onze nieuwe hostingplannen is deze versie niet geïnstalleerd.
  • Databank: Joomla heeft ondersteuning voor verschillende soorten databases. De ondersteunde databases zijn MySQL / MARIADB, MS SQL Server en PostGresql
    • MySQL / MariaDB: Moet hoger zijn dan versie 5.1. Een andere versie die niet zou bestaan in onze nieuwe hostingplannen.
    • MS SQL Server: Moet hoger zijn dan versie 10.50.1600.1
    • PostgreSQL: Moet hoger zijn dan versie 8.3.18
  • Web Server: Samen met de verschillende soorten databases die Joomla ondersteunt, zijn er ook verschillende webservers. Deze omvatten Apache, NGINX en Microsoft IIS (voor Windows VPS)
    • Apache: Het moet hoger zijn dan versie 2.0. Onze gedeelde / bedrijfshostingplannen hebben altijd een relatief up-to-date versie van Apache, dus dit is geen probleem.
    • Nginx: Moet hoger zijn dan versie 1.0. We gebruiken momenteel geen nginx. Dit is echter nog steeds een optie voor VPS en Dedicated Servers.
    • Microsoft IIS: Moet versie 7 zijn. Dit zou echter het Windows-besturingssysteem equivalent zijn dat momenteel alleen beschikbaar is op Windows VPS of Dedicated Servers.

Joomla specificeert geen specifieke vereisten voor de server, zoals RAM of zelfs CPU. Als u echter de neiging heeft om problemen met uw Joomla-site in te voeren, kan het zijn vanwege een gebrek aan middelen.

Afgezien van de vereisten van het basissysteem dat Joomla heeft, kan er ook aanbevolen opties zijn. De basisvereisten zijn minimaal om te zien of Joomla op het systeem wordt uitgevoerd. Dit betekent echter niet dat Joomla optimaal of goed wordt uitgevoerd. U kunt een lijst hieronder vinden van de aanbevolen vereisten voor Joomla.

Joomla! Aanbevolen systeemvereisten

  • PHP-versie: Joomla beveelt aan dat u een PHP-versie gebruikt die 5.6 en hoger of 7,0 en hoger is.
  • Databank:
    • MySQL / MariaDB: Aanbevolen om hoger te zijn dan MySQL 5.5.3
    • MS SQL Server: Ook aanbevolen om hoger te zijn dan 10.50.1600.1
    • PostgreSQL: Aanbevolen om hoger te zijn dan versie 9.1
  • Web Server:
    • Apache: Aanbevolen om hoger te zijn dan Apache 2.4. Onze nieuwere hostingplannen zullen aan deze aanbeveling voldoen
    • Nginx: Aanbevolen om hoger te zijn dan versie 1.8
    • Microsoft IIS: Voor Joomla raden ze aan om alleen versie 7 te gebruiken

Elk Linux webhostingpakket aangeboden door Hostwinds kan aan deze vereisten voldoen.

Als u nog vragen heeft, aarzel dan niet om contact met ons op te nemen via onze livechat of verzending een ticket.

Geschreven door Hostwinds Team  /  maart 31, 2018