Need help? Chat now!

Hostwinds Tutorials

Zoekresultaten voor:


Inhoudsopgave


Minimale systeemvereisten

Magento Systeemvereisten

Trefwoorden: Magento 

Minimale systeemvereisten

Om soepel op elk systeem te lopen, heeft Magento een reeks minimum- en aanbevolen vereisten.De minimumvereisten worden geleverd voor gebruikers die Magento op hun eigen server installeren om te weten wat te wijzen.Hier is deze gids geschreven voor de Magento-versie 1.9.x, waarbij x een nummer is in deze versie van deze grote community-editie.

Minimale systeemvereisten

RAM: Magento vereist minimaal 512 MB RAM op de server om goed te functioneren. Het wordt echter aanbevolen om ten minste 1 GB RAM te hebben voor betere prestaties.

LAMP- of LEMP-omgeving: Wat dit betekent is dat Magento meestal het beste presteert in dit type webomgeving. Lamp staat voor Linux, Apache, MySQL en PHP. Tegelijkertijd is Lemp voor Linux, Nginx, MySQL en PHP. We gebruiken momenteel geen nginx op onze beschikbare gedeelde en zakelijke hostingplannen. De vereisten voor lamp worden echter voldaan aan onze nieuwste hostingplannen.

Besturingssysteem: Magento vereist dat het is geïnstalleerd op een Linux-server met x86-architectuur. Dit betekent dat het niet zou kunnen worden geïnstalleerd op het Windows-besturingssysteem. Aan deze vereiste wordt ook voldaan met onze huidige hostingplannen, zoals Shared en Business hosting.

Webserver-versie: Omdat Magento verschillende webservers ondersteunt, zijn er verschillende versies voor deze die nodig is.

Apache: Met Apache zou Magento vereisen dat ten minste versie 2.x wordt gebruikt, waarbij x een nummer zou zijn om de versie van Apache verder te specificeren. Momenteel maken onze nieuwere hostingplannen gebruik van versie 2.4, dus dit zou geen probleem zijn.

Nginx: Voor NGINX vereist Magento dat ten minste versie 1.7.x wordt gebruikt, waarbij x een nummer is om de versie van NGINX verder te specificeren. Onze hostingplannen gebruiken niet standaard NGINX, maar als u op een VPS-, Cloud- of Dedicated Server root-toegang hebt om een webserver zoals NGINX te installeren.

PHP-versie: Magento stelt dat het ten minste PHP-versie 5.4, 5,5 of 5.6 zou vereisen om te rennen. Met nieuwe gedeelde en zakelijke hostingplannen zou u de mogelijkheid hebben om PHP-versie 5.6 te gebruiken, evenals 7.0.

PHP-modules: PHP gebruikt modules voor bepaalde extra functionaliteit. Magento gebruikt dit om de vele functies te bieden die ze doen. Deze zouden allemaal worden ingeschakeld op onze gedeelde en zakelijke hostingplannen.

  • PDO_MySQL
  • Simplexml
  • mcrypt
  • hash
  • GD
  • DOM
  • iconv
  • ZEEP
  • krullen

Databank: Voor de database van Magento gebruikt het MySQL (evenals MariaDB).

  • MySQL-versie: Magento vereist versie 5.6 van MySQL

SSL: Hoewel het niet nodig is, wordt SSL zwaar aanbevolen bij Magento omdat het als een storefront zal handelen. U wilt ervoor zorgen dat alle informatie van uw klanten is beveiligd en gecodeerd.

Elk Linux webhostingpakket aangeboden door Hostwinds kan aan deze vereisten voldoen.

Mocht u nog vragen hebben over Magento, neem dan contact met ons op via Live Chat, bel ons of dien een ticket in met ons technische ondersteuningsteam.

Geschreven door Hostwinds Team  /  april 10, 2018